Vulnerabilidad del complemento HubSpot WordPress


WPScan y la base de datos nacional de vulnerabilidades del gobierno de los Estados Unidos publicaron un aviso de una vulnerabilidad descubierta en el complemento HubSpot WordPress. La vulnerabilidad expone a los usuarios del complemento a un ataque de falsificación de solicitud del lado del servidor.

Informe de vulnerabilidad de WPScan

Los investigadores de seguridad de WPScan publicaron el siguiente informe:

“HubSpot < 8.8.15 – Colaborador+ Ciego SSRF

Descripción

El complemento no valida la URL del proxy proporcionada al punto final REST del proxy, lo que podría permitir a los usuarios con la capacidad edit_posts (como colaborador predeterminado y superior) realizar ataques SSRF.

Vulnerabilidad de falsificación de solicitud del lado del servidor (SSRF)

Esta vulnerabilidad requiere que un suscriptor de nivel de colaborador inicie sesión para que ocurra la exposición.

El Proyecto de seguridad de aplicaciones web abiertas sin fines de lucro (OWASP), una organización mundial dedicada a la seguridad del software, una vulnerabilidad SSRF puede resultar en la exposición de servicios internos que no están destinados a estar expuestos.

Según OWASP:

“En un ataque de falsificación de solicitud del lado del servidor (SSRF), el atacante puede abusar de la funcionalidad en el servidor para leer o actualizar los recursos internos.

El atacante puede proporcionar o modificar una URL a la que el código que se ejecuta en el servidor leerá o enviará datos y, al seleccionar cuidadosamente las URL, el atacante puede leer la configuración del servidor, como los metadatos de AWS, conectarse a servicios internos como http habilitado. bases de datos o realizar solicitudes posteriores a servicios internos que no están destinados a ser expuestos”.

Los servicios que se supone que no deben estar expuestos son:

  • “Metadatos del servidor en la nube
  • Interfaces HTTP de base de datos
  • Interfaces REST internas
  • Archivos: el atacante puede ser capaz de leer archivos usando URI”

Complemento de WordPress de HubSpot

Más de 200 000 editores utilizan el complemento HubSpot WordPress. Proporciona capacidades relacionadas con CRM, chat en vivo, análisis y marketing por correo electrónico.

La vulnerabilidad descubierta por WPScan señala que se solucionó en la versión 8.8.15.

Sin embargo, el registro de cambios que documenta lo que se actualizó en el software muestra que el complemento HubSpot WordPress recibió actualizaciones adicionales para corregir otras vulnerabilidades.

Aquí hay una lista de las actualizaciones según el registro de cambios oficial, en orden comenzando con la actualización más antigua:

= 8.8.15 (2022-04-07) =
* Fix security issue related to proxy URL

= 8.9.14 (2022-04-12) =
* Fix security issue related to form inputs

= 8.9.20 (2022-04-13) =
* Fix security issue related to sanitizing inputs

Si bien la empresa de seguridad WPScan y la Base de datos nacional de vulnerabilidades afirman que la vulnerabilidad se solucionó en la versión 8.8.15, según el registro de cambios del complemento HubSpot, hubo más correcciones de seguridad hasta la versión 8.9.20.

Por lo tanto, sería prudente actualizar el complemento de HubSpot al menos a la versión 8.9.20, aunque la última versión absoluta del complemento de WordPress de HubSpot, al momento de escribir este artículo, es la versión 8.11.0.

Citas

Lea el informe de vulnerabilidad de WPScan

HubSpot < 8.8.15 – Colaborador+ Ciego SSRF

Lea el informe de la base de datos nacional de vulnerabilidades

CVE-2022-1239 Detalle

Revisa el registro de cambios del complemento de WordPress de HubSpot

Registro de cambios del complemento de WordPress de HubSpot





Consultar el artículo en la publicación original

Vulnerabilidad del complemento HubSpot WordPress
× +info?
A %d blogueros les gusta esto: