La vulnerabilidad crítica del complemento de formulario de WordPress afecta hasta +200.000 instalaciones


Los investigadores de seguridad de Wordfence detallaron una falla de seguridad crítica en el complemento MW WP Form, que afecta a las versiones 5.0.1 y anteriores. La vulnerabilidad permite a actores de amenazas no autenticados explotar el complemento cargando archivos arbitrarios, incluidas puertas traseras PHP potencialmente maliciosas, con la capacidad de ejecutar estos archivos en el servidor.

Complemento de formulario MW WP

El complemento MW WP Form ayuda a simplificar la creación de formularios en sitios web de WordPress utilizando un generador de códigos cortos.

Facilita a los usuarios la creación y personalización de formularios con varios campos y opciones.

El complemento tiene muchas características, incluida una que permite cargar archivos usando el [mwform_file name=”file”] shortcode para fines de recopilación de datos. Es esta característica específica la que se puede explotar en esta vulnerabilidad.

Vulnerabilidad de carga de archivos arbitrarios no autenticados

Un Vulnerabilidad de carga de archivos arbitrarios no autenticados es un problema de seguridad que permite a los piratas informáticos cargar archivos potencialmente dañinos en un sitio web. No autenticado significa que el atacante no necesita estar registrado en el sitio web ni necesita ningún tipo de nivel de permiso que venga con un nivel de permiso de usuario.

Este tipo de vulnerabilidades pueden conducir a la ejecución remota de código, donde los archivos cargados se ejecutan en el servidor, con el potencial de permitir a los atacantes explotar el sitio web y a los visitantes del mismo.

El aviso de Wordfence señaló que el complemento tiene una verificación de tipos de archivos inesperados, pero que no funciona como debería.

Según los investigadores de seguridad:

“Desafortunadamente, aunque la función de verificación de tipo de archivo funciona perfectamente y devuelve falso para tipos de archivos peligrosos, genera una excepción de tiempo de ejecución en el bloque try si se carga un tipo de archivo no permitido, que será capturado y manejado por el bloque catch.

…incluso si se verifica y detecta el tipo de archivo peligroso, solo se registra, mientras la función continúa ejecutándose y se carga el archivo.

Esto significa que los atacantes podrían cargar archivos PHP arbitrarios y luego ceder a esos archivos para activar su ejecución en el servidor, logrando la ejecución remota del código”.

Existen condiciones para un ataque exitoso

La gravedad de esta amenaza depende del requisito de que la opción «Guardar datos de consulta en la base de datos» en la configuración del formulario esté habilitada para poder aprovechar esta brecha de seguridad.

El aviso de seguridad señala que la vulnerabilidad está calificada como crítica con una puntuación de 9,8 sobre 10.

Acciones a tomar

Wordfence recomienda encarecidamente a los usuarios del complemento MW WP Form que actualicen sus versiones del complemento.

La vulnerabilidad está parcheada en la versión laúd del complemento, versión 5.0.2.

La gravedad de la amenaza es particularmente crítica para los usuarios que han habilitado la opción «Guardar datos de consulta en la base de datos» en la configuración del formulario y eso se ve agravado por el hecho de que no se necesitan niveles de permiso para ejecutar este ataque.

Lea el aviso de Wordfence:

¡Actualiza lo antes posible! La carga de archivos arbitrarios críticos no autenticados en el formulario MW WP permite la ejecución de código malicioso

Imagen destacada de Shutterstock/Alexander_P



Consultar el artículo en la publicación original

La vulnerabilidad crítica del complemento de formulario de WordPress afecta hasta +200.000 instalaciones
A %d blogueros les gusta esto: