La actualización del complemento Yoast WordPress provoca errores fatales


El complemento Yoast WordPress SEO lanzó una actualización, pero pronto se hizo evidente que algo salió terriblemente mal para algunos usuarios. Parece que el problema causó errores fatales. Las víctimas afectadas negativamente por la actualización de Yoast tuvieron que volver a una versión anterior de Yoast.

Según un usuario, su instalación de WordPress les alertó de un «error fatal», según el correo electrónico que se les envió.

Yoast solucionó el problema de manera responsable y rápida y publicó una disculpa por lo sucedido.

La actualización del complemento Yoast versión 18.4

Yoast 18.4 tenía la intención de introducir una nueva función que introdujera contenido y marcas de tiempo de datos estructurados con el fin de proteger los derechos de autor utilizando la tecnología blockchain.

La nueva función se conectó a un servicio llamado WordProof que proporciona marcas de tiempo verificables que muestran a los visitantes del sitio cuándo se creó y actualizó el contenido.

Integración fallida de WordProof con Yoast

El servicio WordProof proporciona un certificado de cadena de bloques para certificar una marca de tiempo y una herramienta de infracción de derechos de autor.

El objetivo declarado de WordProof es fomentar la confianza en un sitio web proporcionando pruebas y transparencia.

Según WordProof:

“Internet tiene problemas de raíz que crecen a diario: desconfianza, plagio y fake news. WordProof quiere crear un nuevo estándar para una Internet más confiable y confiable, con la ayuda de la tecnología blockchain”.

Desafortunadamente, la integración de esta función provocó que Yoast fallara gravemente para los usuarios.

En el momento de escribir este artículo, algunos clientes de Yoast indicaron que este error afectaba a las versiones 18.4 y 18.4.1 de Yoast.

Según Yoast, el complemento gratuito Yoast versión 18.4.1 y Yoast SEO Premium 18.2.1 son versiones estables que ya no contienen la nueva función WordProof.

WordProof es una empresa que incluye en sus listas Página sobre nosotros que el esposo y la esposa cofundadores de Yoast son socios.

Síntomas de la actualización del complemento Bad Yoast SEO

La actualización condenada del complemento SEO de Yoast WordPress causó interrupciones masivas para algunos clientes.

Problemas típicos que se informaron:

  • El mapa del sitio XML muestra todos los tipos de contenido, incluido el contenido privado que se supone que no debe estar expuesto
  • La pestaña de configuración de Yoast Search Appearance estaba completamente en blanco.
  • Mensaje de error fatal
  • WordPress envía un mensaje sobre el error del complemento Yoast

Un usuario informó que el núcleo de WordPress envió por correo electrónico un mensaje de alerta sobre el complemento Yoast:

“Desde WordPress 5.2, hay una función integrada que detecta cuando un complemento o tema causa un error fatal en su sitio y le notifica con este correo electrónico automatizado.

En este caso, WordPress detectó un error con uno de sus complementos, Yoast SEO”.

El usuario compartió la documentación de los malos errores del complemento SEO de Yoast:

Captura de pantalla de los errores de actualización de Yoast

Actualización del complemento Bad YoastOtro cliente de Yoast publicó en la página pública de soporte de Yoast para describir sus problemas:

“después de la actualización desde el complemento yoast seo 18.3 -> 18.4 en la página de estado de salud del sitio, puedo ver algunos errores:

…La API REST encontró un error Rendimiento

…La solicitud de la API REST falló debido a un error”.

Un usuario diferente del complemento Yoast escribió a informar a Yoast de un error similar:

“error crítico después de actualizar wordpress 5.9.2 y Yoast 18.4.1

…La solicitud de la API REST falló debido a un error”.

Un problema relacionado con la API REST parecía ser una queja bastante común, ya que había otras víctimas de actualización de Yoast reportándolotambién.

Otro usuario del complemento Yoast escribió que Yoast rompió su sitio web:

“De repente, mi sitio comenzó a mostrar páginas en blanco, páginas de error, páginas con un formato estrecho en un navegador de escritorio (es decir, que no ocupaban toda la pantalla del navegador como solían hacerlo), etc. De repente, tampoco pude editar mi página de inicio…”

Otro petición de ayuda:

“No puedo editar la publicación o la página. Tira error. Cuando desactivé el plugin. Que el problema desaparece.

…error: El editor ha encontrado un error inesperado.”

Yoast asegura que la última versión del complemento SEO ahora es estable

El complemento causó errores fatales para muchos usuarios que comenzaron a publicar en la página de soporte del complemento Yoast en WordPress.org.

Yoast emitió una declaración de disculpa por la actualización problemática:

“A pesar de las pruebas exhaustivas, algunos usuarios, desafortunadamente, experimentaron problemas con Yoast SEO 18.4.

Como se comunicaron rápidamente con nuestro equipo de soporte 24/7, pudimos actuar rápidamente y revertir esta versión.

….Lamentamos mucho cualquier inconveniente que pueda haber experimentado”.

Yoast aseguró a los clientes que las últimas versiones (Yoast SEO 18.4.1 y Yoast SEO Premium 18.2.1) son estables y que revisarían la integración de WordProof en una fecha posterior.

Errores del complemento Yoast SEO

Yoast actualmente no es compatible con PHP 8+. Al menos una de las personas que reportaron un error notó que estaban usando PHP 8.0.

En una pregunta de soporte no relacionada, alguien preguntó si Yoast era compatible con la última versión de PHP, la versión 8.x.

El representante de soporte de Yoast escribió:

“Desafortunadamente, aún no hemos probado completamente el complemento con la versión 8 de PHP. Toda la comunidad de WordPress todavía está trabajando en ello”

Por lo tanto, es posible que para ese usuario en particular, PHP 8.0 pueda haber agravado los problemas.

Yoast recomienda actualizar a las últimas versiones estables de su complemento. Puede ser prudente verificar que su sitio web no esté ejecutando PHP 8.+ y, si es posible, preparar el sitio primero para probar si funciona correctamente.

Citación

Lea la declaración de Yoast sobre la actualización desafortunada

Yoast SEO 18.4.1 y Premium 18.2.1 ya disponibles





Consultar el artículo en la publicación original

La actualización del complemento Yoast WordPress provoca errores fatales
× +info?
A %d blogueros les gusta esto: